Help deploy wisej to IIS

0
0

Howdy,

I’m trying to put my app to the server, but for some reason it’s now working, I was getting an 500 http error.
Changed IIS to provide more details, and complains about web.config section.

Did I changed anything I didn’t? I thing it’s web.config default that was in the project, I believe.
Attached image of the error, and below my web.config

<configuration>
<appSettings>
<!– aki a licensa do server –>
<add key=”Wisej.LicenseKey” value=””/>
<add key=”Wisej.DefaultTheme” value=”Blue-1″/>
</appSettings>
<system.web>
<compilation debug=”true” />
<httpRuntime targetFramework=”4.6″ maxRequestLength=”1048576″/>
<httpModules>
<add name=”Wisej” type=”Wisej.Core.HttpModule, Wisej.Framework”/>
</httpModules>
<customErrors mode=”Off”/>
</system.web>
<system.webServer>
<validation validateIntegratedModeConfiguration=”false”/>
<modules>
<add name=”Wisej” type=”Wisej.Core.HttpModule, Wisej.Framework”/>
</modules>
<handlers>
<add name=”json” verb=”*” path=”*.json” type=”System.Web.HttpForbiddenHandler” />
<add name=”wisej” verb=”*” path=”*.wx” type=”Wisej.Core.HttpHandler, Wisej.Framework”/>
</handlers>
<security>
<requestFiltering>
<requestLimits maxAllowedContentLength=”1073741824″/>
</requestFiltering>
</security>
<defaultDocument enabled=”true”>
<files>
<add value=”Default.html” />
</files>
</defaultDocument>
</system.webServer>
<!–<system.diagnostics>
<trace autoflush=”true” indentsize=”4″>
<listeners>
<remove name=”Default” />
<add name=”Default” type=”System.Diagnostics.TextWriterTraceListener” initializeData=”Trace.log” />
</listeners>
</trace>
</system.diagnostics>–>
</configuration>

  • You must to post comments
0
0

Frank,

I see it’s some feature that is missing in IIS, this is a new server for new deployments.
Can you tell me or is there a list of the features that have to be installed in win2012R2 IIS?
It would be a good idea to have an howto for 2012+ servers IIS configuration, just an suggestion

I’ve found this two threads but still not working for me.
Thanks in advanced,

https://wisej.com/support/question/http-error-500-19
https://www.modernizing-applications.de/ihre-informationen/developer-blog/posts/2018/november/deploying-a-wisej-application/

  • Frank (ITG)
    It´s a problem with your provider locking certain features (see desciption in error message). There is nothing we can really do. Best, Frank
  • Jorge Bastos
    Solved, For WiseJ, the application pool needs to be integrated instead of classic. This information may be handy for someone else. Thanks Frank.
  • You must to post comments
0
0

Frank,

That’s the point, no errors!
Please check this new image from VS, no errors with that structure.

  • You must to post comments
0
0

Hi Frank,

I’m going crazy, don’t see why IIS doesn’t like it, if IIS Express of VS works, I show’ed some file wrong, here’s the correct one and new screenshot.
Any idea? The structure is the one that is in the VS project and came with WiseJ example.

<?xml version=”1.0″?>
<configuration>
<appSettings>
<add key=”Wisej.LicenseKey” value=””/>
<add key=”Wisej.DefaultTheme” value=”Blue-1″/>
</appSettings>
<system.web>
<compilation debug=”true” />
<httpRuntime targetFramework=”4.6″ maxRequestLength=”1048576″/>
<httpModules>
<add name=”Wisej” type=”Wisej.Core.HttpModule, Wisej.Framework”/>
</httpModules>
<customErrors mode=”Off”/>
</system.web>
<system.webServer>
<validation validateIntegratedModeConfiguration=”false”/>
<modules>
<add name=”Wisej” type=”Wisej.Core.HttpModule, Wisej.Framework”/>
</modules>
<handlers>
<add name=”json” verb=”*” path=”*.json” type=”System.Web.HttpForbiddenHandler” />
<add name=”wisej” verb=”*” path=”*.wx” type=”Wisej.Core.HttpHandler, Wisej.Framework”/>
</handlers>
<security>
<requestFiltering>
<requestLimits maxAllowedContentLength=”1073741824″/>
</requestFiltering>
</security>
<defaultDocument enabled=”true”>
<files>
<add value=”Default.html” />
</files>
</defaultDocument>
</system.webServer>
</configuration>

Attachment
  • Frank (ITG)
    Open your web.config in Visual Studio and it will show you the errors in it. Regards, Frank
  • You must to post comments
0
0

Hi Jorge,

it seems to me you posted the wrong web.config file.
The line number in your screenshot showing the error does not fit to the line number in the web.config.

Please verify that the web.config that is used (D:\Websites\dPanel\web.config) uses a correct structure.

Best regards
Frakn

  • You must to post comments
0
0

Help Please!! 🙂

  • You must to post comments
Showing 5 results
Your Answer

Please first to submit.