HTTP-Error 500.19

Answered Closed

Hi all,

on my developer machine everything works fine.

So I tried to publish a wisej user desktop app to a IIS-Webserver 10.0 (Windows Server 2016) via WebDeploy.

When I call the start-url (e.g. localhost) I receive a “HTTP-Error 500.19 Internal Server Error” with ErrorCode=0x80070021.
The error-message says that a configuration section in web.config can not be used: <handlers><add name=”wisej” verb=”*”…>

That’s my web.config file:

<?xml version=”1.0″ encoding=”utf-8″?>
<appSettings file=”Web.Settings.config”></appSettings>
<httpRuntime targetFramework=”4.5″ maxRequestLength=”1048576″ />
<add name=”Wisej” type=”Wisej.Core.HttpModule, Wisej.Core” />
<add name=”wisej” verb=”*” path=”*.wx” type=”Wisej.Core.HttpHandler, Wisej.Core” />
<requestLimits maxAllowedContentLength=”1073741824″ />
<defaultDocument enabled=”true”>
<add value=”Default.html” />
<add name=”GlobaltransEntities” connectionString=”metadata=res://*/GlobEntities.csdl|res://*/GlobEntities.ssdl|res://*/GlobEntities.msl;provider=System.Data.SqlClient;provider connection string=&quot;data source=Hxyz\SQLEXPRESS;initial catalog=Glob;persist security info=True;user id=Glob;password=123;MultipleActiveResultSets=True;App=EntityFramework&quot;” providerName=”System.Data.EntityClient” />
<!–ProjectGuid: ABEEB6EB-B935-48E3-8BE5-2FDF540C03EF–>



Any ideas?




  • You must to post comments
Good Answer

success … I found the solution for me:

A useful thing to know is that even if IIS is enabled on a Windows 2016 server machine, Application Development / Asp.Net still needs to be enabled in Server Manager.

I had to install 2 Features:
– .NET Framework 4.6/ASP.NET 4.6
– WCF-Services/HTTP-Activation

After that the following “Roles and Features” are in the installed features list:

Web Server (IIS)
Web Server
Application Development 4.6
ISAPI Extension
ISAPI Filters
.Net Extensibility 4.6

  • Luca (ITG)
    You probably need to enable WebSocket too. It’s not enabled by default.
  • You must to post comments
Good Answer

okay … now I’m 1 step ahead … I changed the following lines in applicationHost.config:

<section name=”modules” allowDefinition=”MachineToApplication” overrideModeDefault=”Allow” /> <- from “Deny” to “Allow”

<section name=”handlers” overrideModeDefault=”Allow” /> <- from “Deny” to “Allow”

The result is that “default.html” is shown, but the wisej.wx script does not start the application … what’s wrong now?

  • You must to post comments
Showing 2 results