GeoLocation_PositionChanged event not firing under Facebook browser


Anybody else have problems under Facebook’s built-in browser for mobile platforms?

Myself and several users are experiencing an issue where a project does not load properly.  Most would say, who cares? But when you are promoting your app URL on Facebook, and the user see’s it from their mobile device, it always loads in Facebook browser by default.

Confirmed present on FB v.138 on Android 5.0.1 and also iPhone 6s (10.3.3).

  1. Form has a Load event with some code
  2. Form has a Geolocation control, ActiveWatch= true at design time, and a PositionChanged handler event.

Under the integrated FB browser, only Form_Load fires. However, the browser does say “(app name) would like to use your location (allow/block)”

Under other browsers, the Form_Load event fires, and then the GPS_PositionChanged event fires (expected behavior)






  • You must to post comments

This problem is present again in Facebook v146. for Android, possibly iOS.


Steps to reproduce:

1. Create a WiseJ form with GeoLocation on it. ActiveWatch=True
2. Go to website in Chrome, with Android’s Location Services OFF in Android
3. GPS_PositionChanged event fires, returns GPS status of “PermissionDenied”

Now try it in Facebook browser:

(You must Share a link on a Timeline, or in a message, and then load it on an Android phone)

1. Go to same website
2. Facebook browser prompts to allow location. Click Allow
3. WiseJ form loads.
4. GPS_PositionChanged event never fires.


Since my app’s initialization is dependent on the Geolocation’s PositionChanged event being called at least once, the app fails. Every other browser seemingly makes this event fire, even if GeoLocation services are off on the device. Is it possible to override Facebook’s browser behavior by forcing this event to fire, perhaps by using something like Geolocation1.GetCurrentPosition?



  • You must to post comments

Hi Frank. Location services was on, but it was not loading / firing the GPS PositionChanged event. This was going on for several weeks. I just checked again this morning, w/ the latest version of WiseJ and Facebook for Android, and it seems the issue is now resolved.

  • Frank (ITG)
    Thanks Andrew. Glad it´s working ok now ! Best regards, Frank
  • You must to post comments

Hi Andrew,

I am not a Facebook expert, but I think you need to turn on the location services in your FB app to avoid that additional prompt.

Hope that helps.

Best regards

  • You must to post comments
Showing 3 results
Your Answer

Please first to submit.