Visual Studio UI Glitch

Welcome to Wisej Support.
Questions, suggestions and plain old bugs - are all welcome here!
0
0

Good morning,

as shown in the attached image, while in design mode form controls appear as a black box, non matter which theme is used. There is also a black rectangle painted on the bottom of the form. I’ve done a visual studio settings reset but nothing changed. Visual studio theme is set to “light”.

This issue is present only in the 1.3.23 version. (uninstalled, re-downloaded and installed again).

Version 1.3.18 doesn’t show this issue.

I’m using VS 2015 Community on Windows 10.

 

Dario

 

Attachment
  • You must to post comments
0
0

Hi Dario,

Found what has changed and what most likely is the problem. 18 was the last build that directly set the HTML code used in the internal renderer. After 18, the HTML used in the renderer is loaded as a URL from the internal web server used at design time. Your machine is probably blocking the internal web server.

We always had it but before (18 and below) is was used mainly to load resources (images, embedded resources) at design time and if it failed you would notice only when trying to load certain resources. However, it relied on setting the <base> url otherwise the base was “file:///….” and this doesn’t work for css files and creates other problems.

Making the internal renderer fully based on localhost:[port] allows the designer to correctly display third party widgets, load css resources, embedded images, and solves all the problems that a “file:///  url created.

Your machine policy probably blocks System.Net.HttpListener (this is not a firewall issue). Can you please try to run VS as Administrator and see if it makes a difference? We’ll add a check for this and try to display a meaningful message.

/Luca

 

  • You must to post comments
0
0

Hello Dario,

I have never seen this issue before. I tried with VS 2015 Community on a W10 virtual machine and it works here.

We are diffing 18 and 35 to see what may have changed in the designer rendering area. From the screenshot it looks like the designer renderer failed to load, see that the title (part of the non-client (NC) area) is at the bottom meaning that he calculated NC area starts at 0,0 which is wrong. It could also mean that the current theme failed to load.

Can you please try this:

  • Delete C:\Users\[User Name]\AppData\Local\Temp\Wisej\IDE.
  • Try on a different PC or VM.
  • Contact me directly at gianluca[at]iceteagroup.com – I could give you a debug build to track down the issue.

Best,

Luca

 

  • You must to post comments
0
0

Same results with 1.3.27 and the new 1.3.35.

I’m stuck with 1.3.18

  • You must to post comments
0
0

Please try 1.3.27 in the Development tab at https://wisej.com/builds/

 

 

  • You must to post comments
Showing 4 results
Your Answer

Please first to submit.