UserPopup.Showpup and Brotli compression

0
0

Hello,

Strange effect is happening using Brotli and displaying a UserPopup.

The WebPage has a button to display a userpopup right to it.

+ Add 2 buttons to the userPopup  ==> Everything works well.

+ To the Solution, Add a new Item -> Wisej 2 – Brotli. ==> Eveything works well.

+ Add an imageSource or image reference to ONE of the Buttons ==> Bang, the UserPopup doesn’t display

+ Or Add a Textbox ==> Bang, the UserPopup doesn’t display

You can add misc controls and play with the Visible property to see the effect.

It is happening in FireFox,Edge,I.E 11. In chrome the spinner is showing endless in all cases.

Is the way I added Brotli compression correct, or do I need to do something in addition ?

This is one identified situation, but it may happen into other situations.

Wisej 1.0.18 or 1.0.22, VS2015, Win10.

 

Regards.

Attachment
  • You must to post comments
0
0

Frank,

I’m sorry to tell you that from my tests it isn’t solved.

I tried with a very small test App and a more complex App

The results isn’t the sames between them. The bigger App has more buttons with Icons in the Panel.

A reference to Brotli will still create troubles as mentioned earlier.

 

SMALL APP :

IIS Express     Win10 IIS        Win2012 IIS

With Brotli :   NOT  OK              OK                   OK

 

PROD APP :

IIS Express     Win10 IIS        Win2012 IIS

With Brotli :   NOT  OK              NOK                   NOK

  • You must to post comments
0
0

Hi Eric,

this should work (again) with our latest releases (1.5.58 and 2.0.24).

Best regards
Frank

  • You must to post comments
0
0

Hi Frank,

After testing again : it only shows up in Express, when run from VS2015.

I tried deployed on Win10 64 /IIS 10 and also Win2012 /IIS 8 and this is working well.

Regards.

  • You must to post comments
0
0

Hi Eric,

what IIS version are you using ? 32 or 64 bit ? Express ?

TIA
Frank

  • You must to post comments
Showing 4 results
Your Answer

Please first to submit.