Theme not showing in designer

Welcome to Wisej Support.
Questions, suggestions and plain old bugs - are all welcome here!
0
0

I’ve been using WiseJ for a while and recently had to reinstall my Windows OS.
I reinstalled the latest Visual Studio 2017 and WiseJ version 1.5.4 (selected the 2017 check box in the installer)

It fails to load the theme in the Visual Studio designer, I can’t select any fonts or images.
Worse, if I open an existing file that uses a font it crashes.

I updated to 1.5.16 and have the same issue.

I opened your sample HelloWorld project added our theme file and referenced it in web.config. Still no joy.
Ran HelloWorld and the theme displays correctly.

The theme works on our other developer’s machines in visual studio and runs fine on our daily build server.

There is clearly some kind of configuration I’m missing, or something on my PC that is not right.

What should I do to try and resolve this ?
Are there any common things to check for to ensure the correct components are in the correct place and/or that visual studio is integrated properly with WiseJ ?
I there anything I can provide here that would give any clues ?

 

Thanks,

Andi

  • You must to post comments
0
0

Still getting this, I reinstalled WiseJ and updated VS. Did Andi ever find a solution?

 

  • You must to post comments
0
0

Hi Andrew,

I contacted you privately.

  • You must to post comments
0
0

I’m experiencing the same problem.  Project works fine on one computer.  On the other computer, the Theme does not load in the designer. But it loads at Runtime.

For some reason the designer still thinks my theme is is Blue-1, and not my modified Blue-1. I did a low level scan with Process Explorer and it didn’t even seem like my modified theme was being hit when I opened a form in the VS designer (2017 Community, latest version)

Web.config correctly refers to modified theme. I’ve re-read the docs, cleared cache, cleaned/rebuilt/restarted VS, and I’m really at a loss…
this is on 1.5.19 prebuild.
thanks
Andrew
  • You must to post comments
0
0

Hi Andi,

Please clarify some questions.

  1. The other computers you mention are also running Wisej 1.5.17?
  2. The exact same themes files that mis-behave on your computer, do they behave correctly on other computers?
  • You must to post comments
0
0

Hi Andi,

If I understood correctly, your theme files were ok under Wisej 1.5.4.

Since this Wisej release, there were updates to the theme files. Most probably the theme files you are using miss some settings.

Please note that when you build a mixin theme file, you don’t need to remove anything the main theme file, as the settings in the mixin file verwrite the settings in the main theme file.

Please try to use one of the default theme files.

  • You must to post comments
0
0

Hi Andi,

Running the installer should result in a proper instalation. There are a number a things you can try:

  1. Close Visual Studio and run the installer again and select repair.
  2. Restart the computer and open ThemeBuilder before opening Visual Studio.
  3. If you are  opening an existing project, turn on visibility of invisble files and delete the folder .vs

It this doesn’t solve the issue, please report back.

  • You must to post comments
0
0

As an addendum, I moved bits from our theme to a mixin.
The bits I moved are ok.
Whilst I could accept it is all down to a corrupt .theme file, I don’t understand why it would work at runtime but not designtime if the .theme file was invalid.

So I have a way forward, but it worries me as to why the original file is not working in the designer still.

  • Andrew
    Did you ever find a solution?
  • You must to post comments
Showing 7 results
Your Answer

Please first to submit.