Session time Out


Good Morning Please how do i change the default session time out in wisej. I changed it from the Default.json but did not see any change.



Thank you



  • You must to post comments

Hi Godwin,


Please edit Default.json and you will find an commented entry sessionTimeout.

Just add it to the un-commented section and set the number of seconds you want. That’s the way to decrase or increase the timeout.


Forgot to say I re-tested it with 60 secs and 240 secs (default is 120 secs). Both work all right.


If you want to disable the session timeout altogether, you must add an event handler


Wisej.Web.Application.SessionTimeout += Application_SessionTimeout;

and the respective method


private static void Application_SessionTimeout(object sender, HandledEventArgs e)
    // disable timeout
    e.Handled = true;

Hope that helps.

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.