Page Background Image behind Login Form

0
0

Hello Is there a way to get an image to appear in the browser window behind the Login form ?

See screenshot – the browser is just white, we want to put an image there or change the color

Attachment
  • You must to post comments
0
0

Hi Edmond,

there are several ways to achieve that. Let me show 3 of them:

  1. A theme mixin. Create a file name *.mixin.theme and put it into your themes-folder:

    “appearances”:
    {
    “root”:
    {
    “states”:
    {
    “default”:
    {
    “styles”: {
    “backgroundImage”: “https://s3.amazonaws.com/wisej/images/wisej-desktop.jpg”,
    “backgroundSize”: “cover”
    }
    }
    }
    }
    }

  2. Extend default.html
    <body style=”background-image:url(https://s3.amazonaws.com/wisej/images/wisej-desktop.jpg)”>
  3. Use a Stylesheet Extender and add the following style
    body {
    background-image: url(https://s3.amazonaws.com/wisej/images/wisej-desktop.jpg);
    }

Best regards
Frank

 

  • edmond girardi
    Thanks Frank, That Looks Great. I’ll give it a try.
  • edmond girardi
    I tried to add a color to the background form using <body bgcolor=”#E1EEF4″> in default.html. It worked the first time I ran the form via Visual Studio, but all subsequent runs don’t show the color. Now – If I just put a space anywhere in default HTML to cause it to save again – it will show the color when I run it the first time – but not the 2nd, or any other time after the first. I found this same issue when trying to add a style in default.html for the icons I was trying to add into the datagrid view cell. I believe there is a bug here as if it shows the change the first time it should always work. using the developer tools in IE I can see you are rewriting default.html and loosing what I put in there – the body tag becomes ” <body style=”margin: 0px; padding: 0px; width: 100%; height: 100%; overflow: hidden;”>” Testing further – sometimes your changes are merged with mine, sometimes only your changes appear.
  • Frank (ITG)
    Hi Edmond, we tried that here but could not reproduce it. We are not actively rewriting the default.html. We assume that it is rather a caching problem that you are observing. Can you please check your browsers cache settings and try to refresh the browser cache ? Additionally, are you running different apps on the same URL ? Best regards, Frank
  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.