MessageBox issue

Welcome to Wisej Support.
Questions, suggestions and plain old bugs - are all welcome here!
Answered
0
0

Hello,

MessageBox have issue when I put the files on a real server.

If you check http://internals.ro/testwg/default.html and click “Test”, at first time is OK. But if you press again, the message box don’t appear.

Only if you make refresh, you can see again the message box. When I develop the project, in VS2015, this issue is not present.

Thank you

  • You must to post comments
Best Answer
0
0

It’s OK. I added the line with <httpProtocol allowKeepAlive=”false” /> and it’s working OK now. Thank you

  • Luca (ITG)
    Thank you. I still suggest to enable websocket for your server though. It’s probably a missing feature that you can add easily using the “Add Roles and Features” option in the Server Manager.
  • You must to post comments
0
0

Hi Luca,

I removed <httpProtocol allowKeepAlive=”false” /> from web.config and I recompiled with the new version.

It’s OK now.

Thank you.

  • You must to post comments
0
0

Hi Bogdan,

To update you on this issue. You can now remove <httpProtocol allowKeepAlive=”false” /> from Web.config. It is actually preventing the server from using WebSocket and it’s not needed anymore. We have changed the HttpHandler to a fully async handler now and release the requesting thread early when entering modal with http (with WebSocket there is no issue since it a single connection).

The problem was something that I was not aware of: all browsers limit ajax requests (XMLHttpRequest) to 1 per domain. The browser will actually block and wait for the previous request to complete. And IIS IHttpHandler will *not* signal to the browser that the request is completed until the requesting thread is terminated, and closing the socket doesn’t  work because of keep-alive.

Now it works perfectly because of the async http handler.

HTH

Best,

Luca

  • You must to post comments
0
0

Turns out the problem is not with Wisej. Can you please add this to your web.config

 

<system.webServer>

<httpProtocol allowKeepAlive=”false” />

….

 

We’ll add it to the file in the templates. Basically since all the requests coming from Wisej are async using either xhr or websocket, when keep alive is on, subsequent, close, http ajax requests use the previous socket. But when the server has closed the connection apparently the browser cannot reopen it.

In any case, WebSocket is the preferred protocol. But if you add the setting above everything works fine.

I have disabled WebSocket on the sample uploaded earlier: http://demo.wisej.com/desktop/default.html

 

 

  • You must to post comments
0
0

Thank you. The problem is caused by the modal frame not updating the client when it is running on http: the deployed server doesn’t support WebSocket or Microsoft.WebSockets.dll is missing. Anyway, it should work on http as well. Logged with issue #WJ-7238. Will be fixed in the next update tonight.

Added a similar sample on our demo server: http://demo.wisej.com/desktop/default.html

  • You must to post comments
Showing 5 results
Your Answer
Post as a guest by filling out the fields below or if you already have an account.
Name*
E-mail*
Attachment
File Name Size
There are currently no files uploaded.
Maximum number of files 5, maximum file size 3.9MB.
Supported file formats: zip pdf gif jpg bmp png cs vb theme json