Localization - "ru" locale not supported

Welcome to Wisej Support.
Questions, suggestions and plain old bugs - are all welcome here!
0
0

Hello! I try to select “ru” (Default.json) locale, but get default localization. Other locales (“fr”,”lv”…) works without problems.

version 1.5.23.0

  • Nikolajs Valters
    I try “ru” on another machine (Windows Server 2016) – works without problems. On my development machine (Windows 10 1803) with “ru” localization – “ru” setting ignored.
  • Nikolajs Valters
    Under IIS works without problems. Under VS 2017 – “ru” setting ignored.
  • Nikolajs Valters
    I change Windows region from “ru-RU” to “en-US” and after VS restart, all works without problems (“ru” not ignored).
  • You must to post comments
0
0

I tried all the different options:

  • culture=”auto” in Default.json will use the first language specified by the browser and it works fine.
  • Application.CurrentCulture = CultureInfo.GetCultureInfo(“ru”); works for me but not for built-in labels like the DateTimePicker unless you hit refresh. Will log a bug.
  • ?lang=”ru” works well.
  • “culture”: “ru” in Default.json also works well.

 

 

Attachment
  • Nikolajs Valters
    What is your Windows region (locale Format)? Russian (ru-RU)?
  • Nikolajs Valters
    Please set temporary your Windows region format to “Russian” and try again (run under VS).
  • Luca (ITG)
    Still works. Try “culture”:”ru” in Default.json or send a small test case.
  • You must to post comments
0
0

Hi Nikolajs,

Please have a look at Localization documentation.

Detecting/Switching the Browser Language
Wisej automatically recognizes the browser’s language and switches all the application and system resources to use the browser’s language.

You may force the application (user session) to run using a specific language setting the culture property in Default.json. The default value is “auto”. See Configuration for more information about setting the application’s culture.

You may also always force the user session to use a specific language adding the lang argument to the URL. For example, to switch to German: http://localhost/myapp?lang=de. When the current culture changes from the original culture loaded when the session was started, Wisej fires the Application.CultureChanged event.

Are you using the browser language, .json file setting, URL lang argument or the new Application.CurrentCulture property?

  • Nikolajs Valters
    For testing I use json setting (“auto” also not working).
  • Nikolajs Valters
    I test “Application.CurrentCulture” property – also not working
  • You must to post comments
0
0

Hi Nikolajs,

Please confirm the issue is solved.

  • Nikolajs Valters
    Issue is not solved – my windows region – “ru” and with this region under VS 2017 Community “ru” localization is ignored.
  • Nikolajs Valters
    After testing various region settings in windows, I found that when launching application under VS 2017 Community, the localization of the application, equal to the Windows localization, is ignored.
  • You must to post comments
Showing 3 results
Your Answer

Please first to submit.