Solved: Error when trying to run as an App within a folder of a website

Welcome to Wisej Support.
Questions, suggestions and plain old bugs - are all welcome here!

I am trying to run a test wiseJ application as a application folder.


Root Website

\wj  – did a right click in IIS manager and did “change to Application”  Then changed to use its’ own app pool (4.5 integrated)

I took the exact same files and put it at the root of another web on that same server (Win 2012 R2) and the app runs fine.

The error when trying to run it on a application folder is as follows.  I don’t have ApplicationInsights installed on my VS2015 or on the server.  Is this a way of running the WiseJ that is not supported?



Server Error in ‘/wj’ Application.

Could not load file or assembly ‘Microsoft.AI.Web’ or one of its dependencies. The system cannot find the file specified.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.IO.FileNotFoundException: Could not load file or assembly ‘Microsoft.AI.Web’ or one of its dependencies. The system cannot find the file specified.

Source Error:


An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Assembly Load Trace: The following information can be helpful to determine why the assembly ‘Microsoft.AI.Web’ could not be loaded.


WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].







  • You must to post comments
Best Answer

If you put a wisej app (or any other app) inside another app, IIS inherits all the settings of the parent app. You should check the parent app’s web.config, if it tries to load MicrosoftAI then you must add it to the child app /bin (which may trigger new errors for more missing assemblies).  Another option is to remove the inherited values in your web.config. Which can be a nightmare depending on the parent app.

However, this is not a Wisej issue, it’s ASP.NET and IIS. Wisej doesn’t need MicrosoftAI and it can run at the root or as a child app without any problem – unless the parent app creates the problems. 🙂



  • You must to post comments

Thank you for the help.

I removed the insights from the parent web and it worked.

  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.