Data Grid View Top and LHS Border Missing

Welcome to Wisej Support.
Questions, suggestions and plain old bugs - are all welcome here!
0
0

With the latest build Wisej-1.5.23.exe I have noticed that the DGV is missing its Top and LHS Border

Attachment
  • You must to post comments
0
0

Hi Ewan,

still trying to reproduce it, but without a test case I can´t.
If possible, please post here or send to frankATiceteagroup.com

Thanks in advance.

Best regards
Frank

  • Frank (ITG)
    This is being followed up privately. Best regards, Frank
  • You must to post comments
0
0

Hi Frank

Actually it hasn’t DGV seems very sensitive to position on Page

The number at the end of each file name is the distance from the edge of the page

See attached images

  • You must to post comments
0
0

Hi Frank

Apologies

Latest development build appears to have fixed the issue

  • You must to post comments
0
0

Hi Ewan,

thanks for providing more information. But next time, please don´t just edit an existing post but rather reply to it or comment on it.
Otherwise we are not automatically notified and there is a risk of missing your input.

While checking and trying to reproduce we assume that it´s rather some container control that is covering the DataGridView
than actually the RowHeader and CellHeader being hidden.
To verify that, can you please try BringToFront() on your DGV ?
Previous Wisej builds had a problem with a ChildIndex not being set correctly so maybe now controls that have been hiding behind
can be set to the front.

If that does not help, please send us a test case. Otherwise it´s all just a wild guess without having a chance to use your code.

Wisej.Web.DataGridViewSelectionMode.CellSelect is not implemented yet. That applies to the latest Wisej build and all previous version.
So no new behavior here.

Hope that helps.

Best regards
Frank

 

  • You must to post comments
0
0

Hi Frank

I have found the issue.

When you are using a page as opposed to a form, if the DGV is too close to the edge of the page it starts losing lines.

Such as LHS and TOP, A bit further from the edge all the borders are present, but the line between the header and the rows goes.

The minimum distance appears to be around 60 from the left hand edge of the page, for all the lines to display.

There is a Button on the form which was much farther in when I moved it to the left to line up with the other controls which was when the issue seemed to have started but I can’t see why this should be related.

this.dgvRota.SelectionMode = Wisej.Web.DataGridViewSelectionMode.CellSelect – no longer seems to work as soon as you click on a cell the whole row is highlighted.

Hope this helps

Ewan

  • You must to post comments
0
0

Hi Ewan,

I have tried to reproduce the problem using your code snippet but failed so far.
Is only this particular DGV affected in your application ?
You are setting dgvRota.Visible = true; Is your DGV hidden before ?

Would it be possible to send more details ? Structure and content of the DataTable
and designer settings of the DGV ?

If you don´t want to post it here, you can also send it to frankATiceteagroup.com

Thanks in advance.

Best regards
Frank

  • You must to post comments
0
0

Hi Ewan,

are you using a custom theme or any mixin ? Any chance to share some code that helps us to reproduce it ?

Thanks in advance,
Frank

  • You must to post comments
Showing 7 results
Your Answer

Please first to submit.