custom startup loader


How do I replace the default startup loader that shows when a WiseJ app initializes?

I have a .GIF and a .SVG — .SVG would be nice because it is much smaller to download.


thank you!


  • You must to post comments

Using this code I’m getting a weird repeating image in an Android webview.  As you can see the .GIF is repeated at the top of the screen. And in some cases, there is a black-border on the edges that are not the color #3d3d3d.  Android Chrome seems unaffected….


.exactCenter {
position: fixed;
background-color: #3d3d3d;
top: 50%;
left: 50%;
margin-top: -100px;
margin-left: -100px;

<!– div for custom loader –>
<div id=”my-loading-screen” style=”position:absolute; z-index:100; width:100%; height:100%; background-color:#3d3d3d”>
<div class=”exactCenter”>
<img src=”Resources/Images/fixity-loader3.gif” />


  • Levie (ITG)
    Hi Andrew, did you figure out the issue? If you are simply trying to change the loader icon you can place the new .gif in the same directory as your web.config file. If you’re creating your own custom loading page make sure you disable showLoader in default.json. Keep us updated! Best regards, Levie
  • Andrew Niese
    No I did not. The loader showed but the background was not uniform. I tried replacing it with a default gif, showloader, but the background does not stay its custom color (3d3d3d) long enough — it turns to white. So I am without a solution
  • You must to post comments

Hi Andrew,

you can find a couple of ways to customize the loading process of a Wisej app here
(including changing the loader.gif):

Hope that helps.

Best regards

  • Andrew Niese
    Thank you! I missed this in my searching of the forum somehow.
  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.