Create Wisej.Extention Throwing an error - CounterUp.js control



I’m trying to create simple Wisej.Extention as explained in the Extension Guide and i don’t know what i’m missing.

Base on the JustGauge Extension , i have tried to create my own extension (Counter control based on the  countUp.js library []) without successful.

When i’m running the project i’m getting this error:

Wisej: onActionCreate Error creating:  { wisej.web.ext.CountUp….etc

just for mention , i put the scripts in the Platform folder and set the build action to Embedded Resource.

in the OnWebRender method  i called to the “wisej.web.ext.CountUp” as followed :

protected override void OnWebRender(dynamic config)

IWisejControl me = this;

config.className = “wisej.web.ext.CountUp”;
config.value = this.Value;

please see the project attached.


  • You must to post comments

The CountUp extension is at /extensions. It includes all the options available to the widget.

  • You must to post comments

Hi Orel,

You are very close. It’s actually a lot simpler. I have attached the modified project. This one also fires an event on the server “CountTerminated” when it is finished counting and I added the Duration property. It works also at design time.

The main piece missing was the [assembly:WisejResource] property in AssemblyInfo.cs.

The event that I added uses a different syntax, instead of declaring the event as a field which takes memory even when not used, it uses the Events collection which adds the event handler only if the application subscribes to it.

If you look at the updated code I’m sure you’ll appreciate the simplicity and will be able to add the other properties that will let you configure the widget using the additional features..





  • Orel Gabay
    Thanks Luca!! i’m appreciating that you updated the project. i think that its is very important to add this main piece into the Extension Guide . Thanks Orel.
  • Frank (ITG)
    Hi Orel, I have added a note in the Extensions chapter in our documentation. Thanks for your hint. Best regards, Frank
  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.