Change timeout in default.json

0
0

Hello,

 

i’m trying to extend the time out of 5 minutes in default.json but when adding the line and restart my iis server the application doesn’t start anymore.

please let me know what i’m doing wrong

original:

{
“url”: “Default.html”,
“startup”: “LoginPage.Program.Main, LoginPage”
}

 

after adding “respnoseTimout” change:

{
“url”: “Default.html”,
“responseTimeout”: “1800”,
“startup”: “LoginPage.Program.Main, LoginPage”
}

 

_________________________________________________________________________________________________________

below the technichal info which is included in the file

//
// Application Configuration:
//
// All settings are optional.
//
// startup: Full name of the startup method. i.e. “MyApp.Program.Main, MyApp”.
// mainWindow: Full name of a view (Page or Form) created automatically at startup. i.e. “MyApp.MainView, MyApp”.
// theme: Name of the theme, without the extension, to load at startup.
// url: Destination URL. If null, the request must match a web page.
// culture: The default culture of the application. Default: “auto” (detects the culture from the browser.)
// rightToLeft Enables or disables Right to Left mode: true, false or auto. Default: “auto”.
// sessionTimeout: Timeout of the session in seconds. Default: 120. Minimum: 60.
// responseTimeout: Timeout of the Wisej requests in seconds. Default: 300. Minimum: 300.
// Increase this value if you expect your application to process long running requests.
// pollInterval Interval for the automatic polling of the server in milliseconds. Default: 0 (disabled). Minimum: 1000.
// This option is ignored for WebSocket connections.
// secure: Forces the client to use SSL. Default: false.
// showLoader: Loads the wisej ajax loader. Default: true.
// loaderTimeout: Timeout before the appearance of the Ajax loader in milliseconds. Default: 2000. Minimum: 100.
// browserCheck: Custom expression to validate the browser, i.e. “navigator.platform == ‘Win32′”.
// notSupportedUrl: URL of the not-supported page. Wisej will redirect here when the browser is not supported. Default: ‘resource.wx/Wisej.Core/NotSupported.html’
// notAvailableUrl: URL of the not-available page. Wisej will redirect here when the server cannot accept any more sessions. Default: ‘resource.wx/Wisej.Core/NotAvailable.html’
// debug: Enables logging on the client browser console. Default: false.
// enableWebSocket: Enables the user of WebSocket if available. Default: true.
// enableWebSocketCompression Enables compression of incoming WebSocket data. Default: true.
// maxSessions: Maximum number of active sessions (users) before redirecting to notAvailableUrl. Default: -1 (unlimited).
// maxModalStack: Maximum number of nested modal dialogs. Default: 10.
// dropDuplicateClicks Drops all “execute” (clicks) events while there is a pending request. Touch and mouse clicks are still queued and will be executed. Default: false.
// disableClientObjectModel Disables the creation of the JavaScript object model on the client.
// options: Map of platform options. i.e. {debug: true}
// settings: Map of custom application settings. i.e. {jquery: “http://cdn…”, rootPath: “c:\\users\\…”, …}.
//

  • You must to post comments
0
0

Hello,

thanks seems to work, application is still working after restarting the iis server and no time out so far after 5minutes.

Best regards,

bjorn

 

  • You must to post comments
0
0

Björn,

please try without the quotes:

“responseTimeout”: 1800,

Best regards
Frank

  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.