background task



i’ve got a small problem. I’ve made a control with background task (a data import of several records) based on the sample you provide us. I make a thread.sleep(100) after each record and everything works fine in development mode. But on the public server there is no refresh of the screen. I have to make an action (clic, move, etc) to have a refresh of the screen. It looks like no refresh action fired in the client brother. I’ve test the same behavior on chrome, firefox and edge.

Is it a know issue or a problem in my code?

Best regards


  • You must to post comments

it’ solved!

i’ve enabled the websockets and eveithing works fine now.

thanks a lot for your help

best regard


  • Thomas (ITG)
    Great, thanks for your feedback!
  • You must to post comments


i’m on a azure app_service. Websockets are disabled,is it a problem?

web.config are exactly the same :

<?xml version=”1.0″?>
    <add key=”Wisej.LicenseKey” value=””/>
    <add key=”Wisej.DefaultTheme” value=”Blue-1″/>
    <httpRuntime targetFramework=”4.5″ maxRequestLength=”1048576″/>
    <compilation debug=”true” targetFramework=”4.5.1″>
<location path=”.” inheritInChildApplications=”false”>
      <add name=”Wisej” type=”Wisej.Core.HttpModule, Wisej.Core”/>
      <add name=”json” verb=”*” path=”*.json” type=”System.Web.HttpForbiddenHandler”/>
      <add name=”wisej” verb=”*” path=”*.wx” type=”Wisej.Core.HttpHandler, Wisej.Core”/>
        <requestLimits maxAllowedContentLength=”1073741824″/>
    <defaultDocument enabled=”true”>
        <add value=”Default.html”/>

  • You must to post comments

Hi Stéphane,

can you please share some more details about your public server setup ? Is it running on websockets ?
Any chance to provide us with both web.configs to see if we can spot a difference ?

You can send it to me by mail if you want:

Thanks in advance !

Best regards

  • You must to post comments
Showing 3 results
Your Answer

Please first to submit.