Wisej.Web.MenuItem broken in Wisej 2.0.40


Hi WiseJ team – I am (finally) upgrading a project to WiseJ 2.0 – and have installed latest build WiseJ 2.0.40.

During regression testing of the project under the new framework – I have run into a problem with menu items.  My program dynamically refreshes menus when certain conditions happen because there are options that we need to make dynamically available to the user.

To do this – we remove menu items from a MainMenu control, and then re-add them along with new or changed options.

This code worked flawlessly in previous 1.5.x versions.

I have made a simple project to demonstrate this behavior.

Steps to reproduce:

  1. When we load the Window from Program.Main – we call a method to add two menu items dynamically.
  2. The menus we loaded prior to window.show are in place and work when you click on them.
  3. Click the button on the form to clear the menus and add a total of three new menu items as a fresh set.

Expected behavior: the menus should be visibly updated and the new menus should be shown. They should also work when you click on them.

Actual behavior: the menu items do not visually refresh properly – the old ones are still displayed, and clicking on them no longer works.  Also – if you move around the window a little – the menus disappear eventually – I think when the wisej framework figures out that they are not really there.  The new menus never appear.

Also – the MenuItemAdded and MenuItemRemoved events fire correctly as expected, but the user cannot access refreshed/replaced/new menu items added after the window has been displayed.


Please see attached simple program to demonstrate the above behavior.

Thanks in advance for the support – appreciate all you do!



  • You must to post comments

Hi Frank – are you using version 2.0.40 to run the test code?

I can reproduce it on Chrome, Edge, and Internet explorer.  Attached are a couple pics of it being reproduced…

Thanks in advance,



  • You must to post comments

Hi Matthew,

I tried to reproduce the problem using your test case but failed so far.

Does the problem occur on any browser or just a particular one ?

Thanks in advance !

Best regards

  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.