Video does not show up



I am new with Wisej and started my first project with a trial license

On my main page, I have added a TableLayout and within this, I put a Video control (Wisej.Web.Video)

On the load event of the page, I added the code:


Nothing happens…

I tried to set the SourceURL to a Youtube video. And also I put a video into a project folder called Videos and used the following as SourceURL:


The file exists there.

Also I found another post, where somehting similiar was asked and therefor I changed the WebConfig – I added:

<remove fileExtension=”.mp4″ />
<mimeMap fileExtension=”.mp4″ mimeType=”video/mp4″ />


But still nothing. The video isn’t showing up – no error – simply nothing.

What can I do?

THX a lot – Happy new year!

  • You must to post comments
Best Answer

YouTube videos can only be played using the YouTube player which is simple to include using the IFramePanel like in any html page. Maybe we can upload a simple YouTube extension in /extensions to turn it into a Wisej component.

Otherwise the Video and Audio controls in Wisej use the html5 media tags. Try this click on the Media option. The source code is linked here:

If the video doesn’t show it’s probably the browser not supporting the <video> tag. You can always use custom html/javascript video players in Wisej.

  • You must to post comments

THX for your codeproject link

There I found the issue. – I am not allowed to use “~/Videos/HOYA.mp4”

Like in your link, using: “Videos/HOYA.mp4” did it. – Now it works and runs as expected!


THX a lot – Have a nice day

  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.