[SOLVED] Upload control "Click to upload" works on my local machine but not when deployed to server


Locally I can click the message “Click Here to upload files” – and the windows file dialog opens.

However, when the app is launched from the server (Server 2012 64 bit) – clicking the text does not open the Windows file dialog.

Chrome does not work when running application from server, but it does when I run against Visual Studio locally.

IE appears to work locally and from the server.

  • You must to post comments
Best Answer

Try this: http://demo.wisej.com/uploadfiles

The code is here: https://github.com/iceteagroup/wisej-examples/tree/1.5/UploadFiles

If you have a hidden upload button and try to trigger it by using javascript the browser will block it. Check if you have javascript errors. Otherwise you may a chrome extension installed that blocks the upload control.


  • edmond girardi
    That works for me in chrome. The only difference I see is that I have specified the Text Property of the UploadControl with “Click here to select files from your computer”. Which appears in the center of the control for some reason even though the TextAlign is set to Bottom Center- I had opened another post about this but never figured it out. Possibly because I also have an Image and it’s BackgroundImageLayout is set to Center and it’s applying it to both Text and Image ? I’ll dig into my application to see if any code related issue exists – maybe setting some property is affecting it.
  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.