SpeechRecognization Browser error

Welcome to Wisej Support.
Questions, suggestions and plain old bugs - are all welcome here!
0
0

Chrome Browser newest version: Version 56.0.2924.76 (64-bit)

WiseJ version: 1.3.27.

 

I tested the speech recognization with activating a checkbox in my application and all worked well.

When I open the browser  again an error occur, although I never activate the speech.

The error is there after the form is ready loaded.

 

The error did occur not frequently, it is hard to comprehend.

 

Unfortunately I have no short example,

perhaps you already know that problems can occur with speech recognition?

 

Attachment
  • You must to post comments
0
0

The grammar property is empty … perhaps this is the problem?

I have attached a screenshot.

 

The Speech is initialized by these codelines:

speechRecognition1.InterimResults=false;
speechRecognition1.Continuous=true;
speechRecognition1.Language=”de-DE”;
AttachEvent=true;
speechRecognition1.Result+=SpeechRecognition1_Result;
speechRecognition1.NoMatch+=SpeechRecognition1_NoMatch;
speechRecognition1.SpeechEnd+=SpeechRecognition1_SpeechEnd;
speechRecognition1.SpeechStart+=SpeechRecognition1_SpeechStart;

 

The error did occur very rare, at most time all is working well.

 

  • You must to post comments
0
0

The error comes from chrome when the extension assigns the grammar list. Can you try to comment out the Grammars assignment in your app and see if the error still occurs? And please send the list of grammar strings that your setting.

 

  • You must to post comments
Showing 2 results
Your Answer
Post as a guest by filling out the fields below or if you already have an account.
Name*
E-mail*
Attachment
File Name Size
There are currently no files uploaded.
Maximum number of files 5, maximum file size 3.9MB.
Supported file formats: zip pdf gif jpg bmp png cs vb theme json