WiseJ and ASPX on the same site

Welcome to Wisej Support.
Questions, suggestions and plain old bugs - are all welcome here!
0
0

I have an issue that only shows up when I am out of development in VS2015 and on the Webserver (Win2012).

If I run my wiseJ app, all is fine.  If I run a test.aspx webform page I get the following message:

Server Error in ‘/VendorPortal’ Application.

Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: The CodeDom provider type “Microsoft.CodeDom.Providers.DotNetCompilerPlatform.VBCodeProvider, Microsoft.CodeDom.Providers.DotNetCompilerPlatform, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35″ could not be located.

Source Error:
Line 14: <compilers>
Line 15: <compiler language=”c#;cs;csharp” extension=”.cs” type=”Microsoft.CodeDom.Providers.DotNetCompilerPlatform.CSharpCodeProvider, Microsoft.CodeDom.Providers.DotNetCompilerPlatform, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35″ warningLevel=”4″ compilerOptions=”/langversion:6 /nowarn:1659;1699;1701″ />
Line 16: <compiler language=”vb;vbs;visualbasic;vbscript” extension=”.vb” type=”Microsoft.CodeDom.Providers.DotNetCompilerPlatform.VBCodeProvider, Microsoft.CodeDom.Providers.DotNetCompilerPlatform, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35″ warningLevel=”4″ compilerOptions=”/langversion:14 /nowarn:41008 /define:_MYTYPE=\&quot;Web\&quot; /optionInfer+” />
Line 17: </compilers>
Line 18: </system.codedom>

Source File: C:\webs\com.haasdoor.i\web.config Line: 16

Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.6.1649.1

 

 

 

So I looked it up and saw that I needed to add the following to my web.config

<system.codedom>
<compilers>
<compiler language=”c#;cs;csharp” extension=”.cs”
type=”Microsoft.CodeDom.Providers.DotNetCompilerPlatform.CSharpCodeProvider, Microsoft.CodeDom.Providers.DotNetCompilerPlatform, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35″
warningLevel=”4″ compilerOptions=”/langversion:6 /nowarn:1659;1699;1701″/>
<compiler language=”vb;vbs;visualbasic;vbscript” extension=”.vb”
type=”Microsoft.CodeDom.Providers.DotNetCompilerPlatform.VBCodeProvider, Microsoft.CodeDom.Providers.DotNetCompilerPlatform, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35″
warningLevel=”4″ compilerOptions=”/langversion:14 /nowarn:41008 /define:_MYTYPE=\&quot;Web\&quot; /optionInfer+”/>
</compilers>
</system.codedom>

 

Well, that got me this error message.

 

 

 

 

Server Error in ‘/VendorPortal’ Application.

Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: The CodeDom provider type “Microsoft.CodeDom.Providers.DotNetCompilerPlatform.VBCodeProvider, Microsoft.CodeDom.Providers.DotNetCompilerPlatform, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35″ could not be located.

Source Error:
Line 25: type=”Microsoft.CodeDom.Providers.DotNetCompilerPlatform.CSharpCodeProvider, Microsoft.CodeDom.Providers.DotNetCompilerPlatform, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35″
Line 26: warningLevel=”4″ compilerOptions=”/langversion:6 /nowarn:1659;1699;1701″/>
Line 27: <compiler language=”vb;vbs;visualbasic;vbscript” extension=”.vb”
Line 28: type=”Microsoft.CodeDom.Providers.DotNetCompilerPlatform.VBCodeProvider, Microsoft.CodeDom.Providers.DotNetCompilerPlatform, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35″
Line 29: warningLevel=”4″ compilerOptions=”/langversion:14 /nowarn:41008 /define:_MYTYPE=\&quot;Web\&quot; /optionInfer+”/>

Source File: C:\webs\com.haasdoor.i\VendorPortal\web.config Line: 27

Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.6.1649.1

 

I have been trying to fix this all day and haven’t had any luck.  Any help would be appreciated.

 

Shawn

 

  • You must to post comments
0
0

Hi Shawn,

I’m not sure I understand the configuration. I added a test.aspx page to a wisej project and it works without changes:

http://demo.wisej.com/test.aspx

From the message above it looks like asp.net is not fully installed with IIS.

/Luca

  • Shawn Ramirez
    The configuration was a copy / paste of the Web.config from what WiseJ created when the solution was created. It worked fine until I added the ASPX page. That was when i started messing with the web.config. I am not sure what is going on to be honest. I have multiple ASPx sites running on that web server and multiple WiseJ apps. This is something that I haven’t encountered in my years…. I will keep working on it. Thanks Shawn
  • Luca (ITG)
    You don’t need to add any of those settings if the web server is configured to work with ASP.NET. The web.config for Wisej doesn’t interfere since there are basically no settings in there, only 1 handler for *.wx and one module. With ISS the web.config files are inherited. I tried to reproduce and added aspx pages to existing wisej apps without issues for the aspx pages and for the wisej app.
  • You must to post comments
Showing 1 result
Your Answer
Post as a guest by filling out the fields below or if you already have an account.
Name*
E-mail*
Attachment
File Name Size
There are currently no files uploaded.
Maximum number of files 5, maximum file size 3.9MB.
Supported file formats: zip pdf gif jpg bmp png cs vb theme json