Invalid session - set to not time out

Welcome to Wisej Support.
Questions, suggestions and plain old bugs - are all welcome here!
1
0

I have modified my program.vb so that the session isn’t supposed to timeout.  But after about 5 minutes (I didn’t time it but it is several minutes), I get an “Application Error” red dialog box that reads “Invalid Session”.

What am I doing wrong?  This is a monitoring application and needs to just sit on the screen without any user activity.  It shows how one of our systems is running.  I have a timer that runs every 5 minutes to update the data grid views.

It is a cookie session, but I do plan on changing it to cookie-less.

 

Public Sub Main()

Dim window As New Main()
window.Show()

AddHandler Application.SessionTimeout, AddressOf Application_SessionTimeout
End Sub

‘prevent session timeout
Private Sub Application_SessionTimeout(sender As Object, e As System.ComponentModel.HandledEventArgs)
e.Handled = True
End Sub

  • You must to post comments
0
0

In the latest release if you set the sessionTimeout to zero in Default.json the session should never expire.

We added that to start supporting the new Wisej standalone feature, where a Wisej app can run as a single desktop executable.

  • You must to post comments
0
0

Try to add to Default.json

validateClient”: false

Let me know.  It may be a client fingerprint issue. If the request is not validated Wisej will invalidate the session.

  • You must to post comments
1
0

This error appear to be happening when the timer fires to refresh the datagrids.  It doesn’t happen in development, only when on my test server.

If the timer fires and nothing is updated it doesn’t error but if a datagridview has rows added to it (via .datasource=xxx), then it throws the error.

  • You must to post comments
0
0

I have included the error message that I am getting and the default.json settings also.  This issue only appears to happen when a timer is set.

This morning, the first test took less than 1 minute for the message to pop up.  I did a Control-F5 and it took about 10 minutes to pop up.

{
“cookieless”: true,
“startup”: “TechDesk.Program.Main, TechDesk”,
“url”: “Default.html”,
“sessionTimeout”: 1400,
“responseTimeout”: 240,
“debug”: true
}

  • You must to post comments
0
0

The release build that Luca mentioned has just been uploaded.

It´s 1.3.40.

Best regards
Frank

  • You must to post comments
0
0

Hi Shawn,

Thank you for the follow up. Unfortunately .39 was a private build and wasn’t supposed to be picked up by the auto updater. It’s still a good build but please consider it a dev build. The release build is not up yet.

Best,

Luca

  • You must to post comments
0
0

I installed 1.3.39 this morning and recompiled.  The issues appear not to be happening any more.

Thanks,

Shawn

  • You must to post comments
0
0

Timer interval is 5000 (there are 2 timers running, one on the “main” page and one on the “child” page  – both set to 5000.

The session timeout is at the default.  However I am doing the following to try to make it so it will not time out.

Public Sub Main()

Dim window As New Main()
window.Show()

AddHandler Application.SessionTimeout, AddressOf Application_SessionTimeout
End Sub

Private Sub Application_SessionTimeout(sender As Object, e As System.ComponentModel.HandledEventArgs)
e.Handled = True
End Sub

 

 

  • You must to post comments
0
0

What is the timer interval and the session timeout value?

  • You must to post comments
0
0

Looks like the system detects user inactivity and invalidates the session. I’ll get back to you with a solution shortly.

  • You must to post comments
Showing 10 results
Your Answer
Post as a guest by filling out the fields below or if you already have an account.
Name*
E-mail*
Attachment
File Name Size
There are currently no files uploaded.
Maximum number of files 1, maximum file size 3.9MB.
Supported file formats: zip pdf gif jpg bmp png cs vb theme json