Error in Design, missing assembly reference

Welcome to Wisej Support.
Questions, suggestions and plain old bugs - are all welcome here!
Answered
0
0

After installing the latest beta (v. 1.80) opened a new project, and immediately got the error:

Error 1 ¬† The type or namespace name ‘Web’ does not exist in the namespace ‘Disnaris.Test1.Wisej’ (are you missing an assembly reference?)

This comes from the following line in the default Windows1.Designer.cs in the InitializeComponent() procedure:

this.AutoScaleMode = Wisej.Web.AutoScaleMode.Font;

The Intellisense help indeed does not show “Web” after Wisej. It only shows “Program” and “Window1”. The newly-created problem does have references to Wisej.Core and Wisej.Web.

Could this be related to the installing of the new version on top of the older one?

Alex

  • Frank (ITG)
    Hi Alex, Can you please try removing WiseJ and reinstall it ? Looks like there is some mismatch in version, but I could not reproduce that situation here. TIA Frank
  • You must to post comments
Best Answer
0
0

Hi,

You are right! I changed my project name to Alex.Test.WSJ and the problem didn’t show up!

I consider this as closed!

Alex

  • You must to post comments
0
0

Great thank! The issue is that .Wisej corresponds to the root namespace and will basically “invalidate” Wisej. It works form Winforms and VisWebGui since those are not part of their namespace. I hit the same issue myself on other namespaces as well.

 

  • You must to post comments
0
0

Hi Luca,

Just nailed the problem. If I open a new project and leave the Project and Solution name the same (let’s say Test1) then there is no problem. However, I usually name my Solution “Test1” and the project something like “Alex.Test1.Wisej” (as there could be also “Alex.Test1.Winforms”, “Alex.Test1.VisWebGui” etc.). Then the problem with the namespace shows up!!

Alex

PS. Sorry for not replying earlier in one of the other posts, however when I was looking at the Support item list there was showing “0 Answers” to my question, so I was not going in the specific item to check if you had posted an answer, I assumed you had not! Today, I saw your answers with smaller letters as comments under my original question, and the “X Answers” only counting my edits …

A

  • You must to post comments
0
0

Hi,

Tried to remove and re-install. Situation hasn’t changed. What is really strange is that if I include a “using Wisej.Web” in the beginning of the Designer.cs and ¬†remove the Wisej.Web in front of the AutoscaleMode.Font, everything is OK.

At the top of the file, when I type “using Wisej.” intellisense shows a list with the correct namespaces Core {}, Web {} etc. Within the body of the Window1 class, intellisense shows after “Wisej.” only Program and Window1.

Very strange!

Alex

  • Luca (ITG)
    Do you have a namespace “Wisej” in your project by any chance?
  • You must to post comments
Showing 4 results
Your Answer
Post as a guest by filling out the fields below or if you already have an account.
Name*
E-mail*
Attachment
File Name Size
There are currently no files uploaded.
Maximum number of files 1, maximum file size 3.9MB.
Supported file formats: zip pdf gif jpg bmp png cs vb theme json