Error 403.14 - Forbidden after moving project

Welcome to Wisej Support.
Questions, suggestions and plain old bugs - are all welcome here!
0
0

I added a WiseJ project to a solution with a normal ASP project and a ASP WebAPI2 project, which handle some back-end stuff. When I try to run the WiseJ project, I get the following error:

HTTP Error 403.14 – Forbidden
The Web server is configured to not list the contents of this directory.

Things worked fine in the old solution.

As before, there is a web.config file in the WiseJ project listing Default.html as the default document, and Default.html is present.

It’s been a while since I’ve seen this error — any suggestions on where to look?

Thanks.

  • You must to post comments
0
0

Check the Application Pool, it must be Integrated or it doesn’t process the handlers.

Also, sub applications in IIS inherit the parent’s web.config. The main app config may have a setting that prevents IIS from processing requests to pages that don’t actually psychically exist. Try to access the child Wisej application by adding Default.html to the URL.

It’s the <module> setting in wisej’s Web.config that recognizes url without the extension (pretty url) and matches them to a .json config which in turn redirects to the html specified in the json. If IIS is configured to check the existence of the URL it will fail since it thinks that the url without a file is a directory.

  • You must to post comments
Showing 1 result
Your Answer
Post as a guest by filling out the fields below or if you already have an account.
Name*
E-mail*
Attachment
File Name Size
There are currently no files uploaded.
Maximum number of files 5, maximum file size 3.9MB.
Supported file formats: zip pdf gif jpg bmp png cs vb theme json