Deployment Issue

Welcome to Wisej Support.
Questions, suggestions and plain old bugs - are all welcome here!
0
0

I have mad an application, and it runs on my development machine quite well. I went to deploy, following the deployment instructions in the docs section. I could not get the application to get past the swirling icon on loading. The browser page title changes to the application title, but that is it. I assumed I had missed a step. The server is 2012R2 and IIS is 8.5.9600.16384

I created a test site. I created a simple html page to see if the site was accessible. I could open the page remotely. I checked the server, and noticed web sockets were not installed. I installed web sockets and enabled on the site. I copied the files from the sample “Hello World”, so I had a bench mark site. I created a new application pool and assigned the .net clr version V4.0.30319 (I believe this equates to 4.6.2) I set the managed pipeline mode to integrated. I added my server licence to the config file, and checked it existed on the server under programdata.

I thought I had all bases covered, but still I cannot get past the swirling loading icon. Any suggestions. I have not included the sample code, as I am using the sample to try and get the server working.

  • You must to post comments
0
0

Did you solve it?

  • John Sainsbury
    No. I am able to see the html contents of the default.html on the client, but the window class is not loading. I have checked folder permissions and “test settings” and all is okay. I am currently working through differences between a working site and this one, to see what may be different. I first thought it was an authorization issue, but now I am tending to believe it may be a .net issue.
  • John Sainsbury
    Update. I have the test site working, however I cannot explain why my other sites work. It does appear I have mixed versions of .net 4 installed on the server. Of the basic system files referenced, the version can be 4.0.30319.33440; 4.6.1069.1; 4.6.1055.0; 4.6.1068.2; 4.6.1075.0. I have downloaded the install for 4.6.2 and will hopefully update the files referenced. The short work around was to copy these system files to the bin folder, from my development machine. Visiting all settings in IIS seemed to help. I made no changes, so it would appear the server is now able to reference the correct versions in the bin folder. I am going to try a new site when I apply the 4.6.2 patch, and see if this is actually the issue. The one thing I cannot stop is the timeout warning is displayed immediately when the window is displayed, even though I have set the timeout in JSON config file to 2000.
  • You must to post comments
0
0

Hello John,

If you get  the swirling icon then wisej is responding correctly. Any license issue of any kind will never stop the server from working, in the worst case you get an alert box. Also the WebSocket feature is not a show stopper.

Can you please check with F12 if there is any error in the browser?

You can also add this in Web.config inside <configuration>

 <system.diagnostics>
   <trace autoflush="true" indentsize="4">
     <listeners>
       <add name="myListener" type="System.Diagnostics.TextWriterTraceListener" initializeData="TextWriterOutput.log" />
       <remove name="Default" />
     </listeners>
   </trace>
 </system.diagnostics>

Let me know if you get any log in the application’s root folder.

Also, is there anything else on the IIS server?

If you can, send me the IP or url of the server, you can send to me directly or to support@wisej.com.

Best,

Luca

  • You must to post comments
Showing 2 results
Your Answer
Post as a guest by filling out the fields below or if you already have an account.
Name*
E-mail*
Attachment
File Name Size
There are currently no files uploaded.
Maximum number of files 5, maximum file size 3.9MB.
Supported file formats: zip pdf gif jpg bmp png cs vb theme json